XML::LibXMLのせいでNet::Google::Calendarがcpan installできない。

Raspberry piにNet::Google::Calendarを入れようとしたのですが、XML::Atom::Feedとかのmakeに失敗してcpan installできませんでした。
XML::Atom::Feedとかの依存の大元がXML::LibXMLだったので、こいつをinstallしようとしたのですが、libxml2がないとかわけのわからんことを言い出してmakeに失敗しました。
いや、libxml2入ってるから…と思ってたのですが、よく考えたらlibxml2のdevelを入れてませんでした。

Debian系統なら以下のコマンドを実行後にcpan install Net::Google::Calendarで解決できるかもしれません。

$sudo apt-get install libxml2-dev

コメントを残す

お手数ですが半角数字で計算結果を入力してください。 *